Remote
RFC Editor
@rfceditor@mastodon.online
Announcements of official documents published by the RFC Editor at rfc-editor.org
0 Followers
0 Following
4 Posts
Joined March 07, 2023
Replying to
DTLS (in any DTLS version); it pertains to TLS only. This document updates RFC 9325. It discusses post-quantum cryptography and the security and privacy improvements in TLS 1.3 as the rationale for the update. This document is a product of the Using TLS in Applications Working Group of the IETF. 2/2
Open post
RFC 9851: TLS 1.2 is in Feature Freeze, R. Salz, et al., https://www.rfc-editor.org/info/rfc9851 #RFC Use of TLS 1.3, which fixes some known deficiencies in TLS 1.2, is growing. This document specifies that no changes will be approved for TLS 1.2 outside of urgent security fixes (as determined by TLS Working Group consensus), new TLS Exporter Labels, and new Application-Layer Protocol 1/2
0
0
0
0
Open post
RFC 9954: Hybrid Key Exchange in TLS 1.3, D. Stebila, et al., https://www.rfc-editor.org/info/rfc9954 #RFC Hybrid key exchange refers to using multiple key exchange algorithms simultaneously and combining the result with the goal of providing security even if a way is found to defeat the encryption for all but one of the component algorithms. It is motivated by the transition to post-quantum 1/2
0
0
1
0